FailuresAccessorIsElementsDeletionPermitted(IListElementId, String) Method |
Checks if resolution of the failures by deleting given collection of elements is permitted.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsElementsDeletionPermitted(
IList<ElementId> idsToDelete,
out string reason
)
Public Function IsElementsDeletionPermitted (
idsToDelete As IList(Of ElementId),
<OutAttribute> ByRef reason As String
) As Boolean
public:
bool IsElementsDeletionPermitted(
IList<ElementId^>^ idsToDelete,
[OutAttribute] String^% reason
)
member IsElementsDeletionPermitted :
idsToDelete : IList<ElementId> *
reason : string byref -> bool
Parameters
- idsToDelete IListElementId
-
The Ids of elements to be deleted.
- reason String
-
A localized string explaining reason why the elements cannot be deleted.
Return Value
Boolean
True if resolution of the failures by deleting given elements is permitted
Exceptions
Remarks
Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies
that given elements can be deleted in the current state of the document.
See Also