ExternalServiceRegistryGetService Method |
Returns an instance of an object that represents the external service with the given Id.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ExternalService GetService(
ExternalServiceId serviceId
)
Public Shared Function GetService (
serviceId As ExternalServiceId
) As ExternalService
public:
static ExternalService^ GetService(
ExternalServiceId^ serviceId
)
static member GetService :
serviceId : ExternalServiceId -> ExternalService
Parameters
- serviceId ExternalServiceId
-
Id of the service.
Return Value
ExternalService
The instance of the service or NULL if it cannot be found.
Exceptions
Remarks
The returned instance is either of type SingleServerService or MultiServerService.
Users should cast the returned object to one of the classes if they need access to active servers.
See Also