RebarShapeDefinitionSetParameterFormula Method |
Associate a formula with the parameter.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetParameterFormula(
ElementId paramId,
string formula
)
Public Sub SetParameterFormula (
paramId As ElementId,
formula As String
)
public:
void SetParameterFormula(
ElementId^ paramId,
String^ formula
)
member SetParameterFormula :
paramId : ElementId *
formula : string -> unit
Parameters
- paramId ElementId
-
Id of a parameter in the definition.
- formula String
-
The formula expressed as a string. The string is exactly what a user would
type into the Family Types dialog, e.g. "Total Length*3.14159*(Bar Diameter/2)*(Bar Diameter/2)"
Exceptions
See Also