MechanicalEquipmentSetRemove Method |
Removes member element ids from the mechanical equipment set.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Remove(
ISet<ElementId> elemIds
)
Public Sub Remove (
elemIds As ISet(Of ElementId)
)
public:
void Remove(
ISet<ElementId^>^ elemIds
)
member Remove :
elemIds : ISet<ElementId> -> unit
Parameters
- elemIds ISetElementId
-
Element ids to be removed from the mechanical equipment set.
ExceptionsException | Condition |
---|
ArgumentException |
One or more element ids was not permitted to be removed from the mechanical equipment set.
All elements should be a member of the mechanical equipment set.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
If all the members are removed, the instance of the mechanical equipment set is automatically deleted.
See Also