ViewSetFilterVisibility Method |
Sets the visibility of the elements associated with a filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFilterVisibility(
ElementId filterElementId,
bool visibility
)
Public Sub SetFilterVisibility (
filterElementId As ElementId,
visibility As Boolean
)
public:
void SetFilterVisibility(
ElementId^ filterElementId,
bool visibility
)
member SetFilterVisibility :
filterElementId : ElementId *
visibility : bool -> unit
Parameters
- filterElementId ElementId
-
The ElementId of the filter.
- visibility Boolean
-
True if the elements associated with the filter are visible in the view, false otherwise.
Exceptions
Remarks
If the filter is not currently applied to the view, this will add the filter with the specified visibility.
See Also