DocumentExport(String, String, STEPExportOptions) Method |
Exports the current view or a selection of views in STEP format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
STEPExportOptions options
)
Public Function Export (
folder As String,
name As String,
options As STEPExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
STEPExportOptions^ options
)
member Export :
folder : string *
name : string *
options : STEPExportOptions -> bool
Parameters
- folder String
-
Output folder, into which file(s) will be exported. The folder must exist.
- name String
-
Either the name of a single file or a prefix for a set of files.
If empty, automatic naming will be used.
- options STEPExportOptions
-
Various options applicable to the STEP format.
Return Value
Boolean
True if successful, otherwise False.
Exceptions
Remarks
All the views must be 3D views for the Export to succeed.
See Also