STEPExportOptions Class

The export options used by exporting STEP format file.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBIMExportOptions
    Autodesk.Revit.DBSTEPExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class STEPExportOptions : BIMExportOptions

The STEPExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodSTEPExportOptions Constructs a new instance of STEPExportOptions with default values of all properties.
Top
Properties
 NameDescription
Public propertyApplicationProtocol The Application Protocol of the exported STEP file.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BIMExportOptions)
Public propertyTargetUnit The unit type of geometry in the resultant STEP file. Default value is ExportUnit::Default.
Public propertyViewId The element id of the 3D view to export. InvalidElementId by default.
(Inherited from BIMExportOptions)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from BIMExportOptions)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also