STEPExportOptions Class

The export options used by exporting STEP format file.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBIMExportOptions
    Autodesk.Revit.DBSTEPExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class STEPExportOptions : BIMExportOptions

The STEPExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodSTEPExportOptions Constructs a new instance of STEPExportOptions with default values of all properties.
Top
Properties
 NameDescription
Public propertyApplicationProtocol The Application Protocol of the exported STEP file.
Public propertyTargetUnit The unit type of geometry in the resultant STEP file. Default value is ExportUnit::Default.
Top
Methods
 NameDescription
Top
See Also