RebarCurvesDataGetAddedBarGeometry Method |
Gets the added curves that will represent the bar at index barIndex.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Curve> GetAddedBarGeometry(
int barIndex
)
Public Function GetAddedBarGeometry (
barIndex As Integer
) As IList(Of Curve)
public:
IList<Curve^>^ GetAddedBarGeometry(
int barIndex
)
member GetAddedBarGeometry :
barIndex : int -> IList<Curve>
Parameters
- barIndex Int32
-
The index of the bar. Should be a number between 0 and GetNumberOfBarGeometry() - 1.
Return Value
IListCurve
Returns the curves that will represent the bar at index barIndex. The hooks plane normals will be applied on these curves.
Exceptions
See Also