IExternalResourceServerSupportsExternalResourceType Method |
Implement this method to indicate whether the server can provide data for a specified type of external resource.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool SupportsExternalResourceType(
ExternalResourceType type
)
Function SupportsExternalResourceType (
type As ExternalResourceType
) As Boolean
bool SupportsExternalResourceType(
ExternalResourceType^ type
)
abstract SupportsExternalResourceType :
type : ExternalResourceType -> bool
Parameters
- type ExternalResourceType
-
The ExternalResourceType of interest to the caller. For example, KeynoteTable - to determine
if the server provides data for Revit's keynote table.
Return Value
Boolean
True if the server supports the specified type of external resource
See Also