ImageInstanceWidthScale Property |
The factor applied to the width of the
ImageType to calculate the
Width of the ImageInstance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double WidthScale { get; set; }
Public Property WidthScale As Double
Get
Set
public:
property double WidthScale {
double get ();
void set (double value);
}
member WidthScale : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The given value for widthScale results in a width that is more than 30000 feet.
-or-
When setting this property: The given value for widthScale results in a height that is more than 30000 feet because LockProportions is set to true.
|
ArgumentOutOfRangeException |
When setting this property: The given value for widthScale must be non-negative.
|
Remarks
See Also