ViewShapeBuilderValidateCurve(Curve) Method |
Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ValidateCurve(
Curve GCurve
)
Public Function ValidateCurve (
GCurve As Curve
) As Boolean
public:
bool ValidateCurve(
Curve^ GCurve
)
member ValidateCurve :
GCurve : Curve -> bool
Parameters
- GCurve Curve
-
Curve object to be validated.
Return Value
Boolean
True is %GCurve% is acceptable as a part of view-specific shape representation being built.
Exceptions
Remarks
This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
Validation conditions depend on the type of view for which the shape representation is intended.
For plan views, a curve is expected to be planar and non-degenerate (e.g., NOT a circle of zero radius).
See Also