LabelUtilsGetLabelForBuiltInParameter(ForgeTypeId, LanguageType) Method

Gets the user-visible name for a built-in parameter in a specific LanguageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string GetLabelForBuiltInParameter(
	ForgeTypeId parameterTypeId,
	LanguageType language
)

Parameters

parameterTypeId  ForgeTypeId
Identifier of the built-in parameter to get the user-visible name.
language  LanguageType
The desired LanguageType to get the user-visible name in.

Return Value

String
The built-in parameter name in the desired LanguageType.
Exceptions
ExceptionCondition
InvalidOperationException Thrown when the built-in parameter cannot be found.
InvalidOperationException Thrown when the desired LanguageType cannot be found for the built-in parameter name.
See Also