SolidOrShellTessellationControlsLevelOfDetail Property |
An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double LevelOfDetail { get; set; }
Public Property LevelOfDetail As Double
Get
Set
public:
property double LevelOfDetail {
double get ();
void set (double value);
}
member LevelOfDetail : float with get, set
Property Value
Double
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The given value for levelOfDetail must lie between 0 and 1 (inclusive).
|
Remarks
Smaller values yield coarser triangulations (fewer triangles), while larger values yield finer
triangulations (more triangles).
See Also