IExportContext2DOnFaceEdge2D Method |
This method is called when a Face edge is being output.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxRenderNodeAction OnFaceEdge2D(
FaceEdgeNode node
)
Function OnFaceEdge2D (
node As FaceEdgeNode
) As RenderNodeAction
RenderNodeAction OnFaceEdge2D(
FaceEdgeNode^ node
)
abstract OnFaceEdge2D :
node : FaceEdgeNode -> RenderNodeAction
Parameters
- node FaceEdgeNode
-
An output node that represents a Face edge.
Return Value
RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry
(line or polyline segments) for this face edge, or otherwise return RenderNodeAction.Skip.
Note: if the export is performed for the view in non-Wireframe display style
tesselated geometry will be output regardless of the return value.
RemarksNote that this method is invoked only if the custom exporter
was set up to include geometric objects in the output stream.
See IncludeGeometricObjects for mode details.
Note: if the export is performed for the view in non-Wireframe display style
this method will be called regardless of whether the object will be eventially output,
i.e. even if it's occluded by another element.
See Also