FamilySymbolSetStructuralSection Method |
Sets the structural section in element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetStructuralSection(
StructuralSection structuralSection
)
Public Sub SetStructuralSection (
structuralSection As StructuralSection
)
public:
void SetStructuralSection(
StructuralSection^ structuralSection
)
member SetStructuralSection :
structuralSection : StructuralSection -> unit
Parameters
- structuralSection StructuralSection
-
Structural section with values that will be set.
Exceptions
Remarks
Only beams, braces and structural columns can have a structural section.
To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.
See Also