MassLevelDataMaterialType Property |
Indicates if the material used for the graphical appearance is by category or a specific material, or
if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic MassSurfaceDataMaterialType MaterialType { get; set; }
Public Property MaterialType As MassSurfaceDataMaterialType
Get
Set
public:
property MassSurfaceDataMaterialType MaterialType {
MassSurfaceDataMaterialType get ();
void set (MassSurfaceDataMaterialType value);
}
member MaterialType : MassSurfaceDataMaterialType with get, set
Property Value
MassSurfaceDataMaterialType
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The material type does not fall within an appropriate range.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
See Also