MassSurfaceDataMaterialType Enumeration |
Indicates how the visualization material for the MassSurfaceData is calculated.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum MassSurfaceDataMaterialType
Public Enumeration MassSurfaceDataMaterialType
public enum class MassSurfaceDataMaterialType
type MassSurfaceDataMaterialType
MembersMember name | Value | Description |
---|
NormalMaterial | 0 |
The visualization material for the MassSurfaceData will be taken from the material
associated with the object style of the subcategory of the MassSurfaceData if the
materialId is InvalidElementId, or the MassSurfaceData will use the specific material
indicated by the materialId property if its value is an ElementId of a MaterialElement.
|
MaterialByConstruction | -2 |
The visualization material for the MassSurfaceData will be taken from the
material assigned to the ConceptualConstructionType which is assigned to the
MassSurfaceData.
|
See Also