RebarShapeDefinitionBySegmentsAddConstraintParallelToSegment Method |
Constrain the length of a segment by parameterizing its length.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddConstraintParallelToSegment(
int iSegment,
ElementId paramId,
bool measureToOutsideOfBend0,
bool measureToOutsideOfBend1
)
Public Sub AddConstraintParallelToSegment (
iSegment As Integer,
paramId As ElementId,
measureToOutsideOfBend0 As Boolean,
measureToOutsideOfBend1 As Boolean
)
public:
void AddConstraintParallelToSegment(
int iSegment,
ElementId^ paramId,
bool measureToOutsideOfBend0,
bool measureToOutsideOfBend1
)
member AddConstraintParallelToSegment :
iSegment : int *
paramId : ElementId *
measureToOutsideOfBend0 : bool *
measureToOutsideOfBend1 : bool -> unit
Parameters
- iSegment Int32
-
Index of the segment (0 to NumberOfSegments - 1).
- paramId ElementId
-
Id of a parameter to drive the constraint. To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
- measureToOutsideOfBend0 Boolean
-
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
- measureToOutsideOfBend1 Boolean
-
Choose between two possibilities for the second reference of the length dimension.
ExceptionsException | Condition |
---|
ArgumentException |
iSegment is not between 0 and NumberOfSegments.
-or-
paramId is not the id of a shared parameter in the current document,
or its unit type is not UT_Reinforcement_Length or UT_Angle.
|
ArgumentNullException |
A non-optional argument was null
|
See Also