DirectShapeLibraryFindDefinitionType Method |
Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId FindDefinitionType(
string id
)
Public Function FindDefinitionType (
id As String
) As ElementId
public:
ElementId^ FindDefinitionType(
String^ id
)
member FindDefinitionType :
id : string -> ElementId
Parameters
- id String
-
Definition id. Expected to be unique.
Return Value
ElementId
Element id of a DirectShapeTypeElement
Exceptions
See Also