Returns the boundary of the Zone.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CurveArray Boundary { get; }
Public ReadOnly Property Boundary As CurveArray
Get
public:
property CurveArray^ Boundary {
CurveArray^ get ();
}
member Boundary : CurveArray with get
Property Value
CurveArray
RemarksThis property is used to retrieve the segments that constitute the boundary of the Zone.
Each Zone may have several regions, each of which have several segments hence the data is returned
in the form of an array of boundary segment arrays. See the Zone.BoundarySegment object for more
details about the segments that make up the Zone topology.
See Also