LoadBaseOrientTo Property |
The load orientation option.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic LoadOrientTo OrientTo { get; set; }
Public Property OrientTo As LoadOrientTo
Get
Set
public:
property LoadOrientTo OrientTo {
LoadOrientTo get ();
void set (LoadOrientTo value);
}
member OrientTo : LoadOrientTo with get, set
Property Value
LoadOrientTo
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: orientTo is not permitted for this type of load.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
For hosted load only LoadOrientTo.Project and LoadOrientTo.HostLocalCoordinateSystem are permitted.
For non-hosted load only LoadOrientTo.Project and LoadOrientTo.WorkPlane are permitted.
To determine if load is hosted use
IsHosted property.
See Also