IDockablePaneProviderSetupDockablePane Method |
Method called during initialization of the user interface to gather information about a dockable pane window.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxvoid SetupDockablePane(
DockablePaneProviderData data
)
Sub SetupDockablePane (
data As DockablePaneProviderData
)
void SetupDockablePane(
DockablePaneProviderData^ data
)
abstract SetupDockablePane :
data : DockablePaneProviderData -> unit
Parameters
- data DockablePaneProviderData
-
Container for information about the new dockable pane. Implementers should set the
FrameworkElement and InitialState Properties. Optionally, providers can set the
ContextualHelp property if they wish to provide or react to help requests on the pane,
or override the default EditorInteraction property by setting it here.
See Also