FilteredElementCollectorToElementIds Method |
Returns the complete set of element ids that pass the filter(s).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> ToElementIds()
Public Function ToElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ ToElementIds()
member ToElementIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
The complete set of element ids.
ExceptionsException | Condition |
---|
InvalidOperationException |
The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
|
Remarks
This will reset the collector to the beginning and extract all elements that pass the applied filter(s).
If you have an active iterator to this same collector it will be stopped by this call.
See Also