ExternalFileUtilsGetAllExternalFileReferences Method |
Gets the ids of all elements which are external file references.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ICollection<ElementId> GetAllExternalFileReferences(
Document aDoc
)
Public Shared Function GetAllExternalFileReferences (
aDoc As Document
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetAllExternalFileReferences(
Document^ aDoc
)
static member GetAllExternalFileReferences :
aDoc : Document -> ICollection<ElementId>
Parameters
- aDoc Document
-
A Revit Document.
Return Value
ICollectionElementId
The ids of all elements which are external file references.
Exceptions
Remarks
This function will not return the ids of nested Revit links;
it only returns top-level references.
See Also