StairsRunActualRunWidth Property |
Specifies the value of the tread width excluding the width of independent side supports.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double ActualRunWidth { get; set; }
Public Property ActualRunWidth As Double
Get
Set
public:
property double ActualRunWidth {
double get ();
void set (double value);
}
member ActualRunWidth : float with get, set
Property Value
Double
The actual width of the stairs run, 0.0 if the run is a sketched run.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: The given value for runWidth must be greater than 0 and no more than 30000 feet.
-or-
When setting this property: The runWidth is too small or too large to be used as actual run width, probably it
doesn't satisfy the layout generation restriction of the stairs run.
|
InvalidOperationException |
When setting this property: The stairs run is sketched so the data being set is not applicable.
|
See Also