BuiltInFailuresRenderFailures Class

Failures related to rendering.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresRenderFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RenderFailures

The BuiltInFailuresRenderFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberLightParametersNotInRange The value should be in range of [Value] and [Value].
Public propertyStatic memberLightSourceInsideGeometry Light source is inside solid geometry. No light will be emitted during rendering.
Public propertyStatic memberProhibitDeletionLightSource The light source cannot be deleted with UI.
Public propertyStatic memberRenderLibNotInstalledWarn Rendering library has not been installed, so the third party geometry cannot be created.
Top
See Also