TableViewGetAvailableParameterCategories Method |
Get all available parameter categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> GetAvailableParameterCategories(
SectionType sectionType,
int row
)
Public Function GetAvailableParameterCategories (
sectionType As SectionType,
row As Integer
) As IList(Of ElementId)
public:
IList<ElementId^>^ GetAvailableParameterCategories(
SectionType sectionType,
int row
)
member GetAvailableParameterCategories :
sectionType : SectionType *
row : int -> IList<ElementId>
Parameters
- sectionType SectionType
-
The section the row lies in.
- row Int32
-
The row.
Return Value
IListElementId
The available parameter categories.
ExceptionsException | Condition |
---|
ArgumentException |
The sectionType is not a valid type for this view.
|
ArgumentOutOfRangeException |
The given row number row is invalid.
-or-
A value passed for an enumeration argument is not a member of that enumeration
|
See Also