SubelementIsValidType Method |
Checks if given type is valid for this subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidType(
ElementId typeId
)
Public Function IsValidType (
typeId As ElementId
) As Boolean
public:
bool IsValidType(
ElementId^ typeId
)
member IsValidType :
typeId : ElementId -> bool
Parameters
- typeId ElementId
-
ElementId of the type to check.
Return Value
Boolean
True if subelement can have a type assigned and this type is valid for this subelement, false otherwise.
Exceptions
Remarks
A type is valid for a subelement if it can be assigned to the subelement.
See Also