UpdaterDataGetAddedElementIds Method |
Returns set of elements newly added to the document.
This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetAddedElementIds()
Public Function GetAddedElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAddedElementIds()
member GetAddedElementIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
Set of elements that were added to the document and triggered the call to execute()
Note: This will only return elements if the trigger registered for the associated updater
contains the ChangeType returned by Element::getChangeTypeElementAddition()
See Also