RebarContainerAppendItemFromRebar Method |
Appends an Item to the RebarContainer. Fills its data on base of the Rebar.
Will throw exception if given rebar is not shape driven.
Will throw exception if given rebar has moved bars in set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarContainerItem AppendItemFromRebar(
Rebar rebar
)
Public Function AppendItemFromRebar (
rebar As Rebar
) As RebarContainerItem
public:
RebarContainerItem^ AppendItemFromRebar(
Rebar^ rebar
)
member AppendItemFromRebar :
rebar : Rebar -> RebarContainerItem
Parameters
- rebar Rebar
-
The Rebar.
Return Value
RebarContainerItem
The Rebar Container Item.
ExceptionsException | Condition |
---|
ArgumentException |
The RebarShape of rebar has End Treatments
-or-
Can't create container from free-form rebar.
-or-
Can't create container from Rebar with moved bars.
|
ArgumentNullException |
A non-optional argument was null
|
See Also