TopographySurfaceFindPoints Method |
Filters and returns only the points of the topography surface which lie within the input bounding box.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<XYZ> FindPoints(
Outline boundingBox
)
Public Function FindPoints (
boundingBox As Outline
) As IList(Of XYZ)
public:
IList<XYZ^>^ FindPoints(
Outline^ boundingBox
)
member FindPoints :
boundingBox : Outline -> IList<XYZ>
Parameters
- boundingBox Outline
-
The 3D bounding box.
Return Value
IListXYZ
The result points within the 3D bounding box
Exceptions
Remarks
This applies to TopographySurface, SiteSubRegion, and the topography surface associated with a BuildingPad element.
See Also