TableSectionDataSetCellStyle(Int32, Int32, TableCellStyle) Method |
Sets a cell's style
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCellStyle(
int nRow,
int nCol,
TableCellStyle Style
)
Public Sub SetCellStyle (
nRow As Integer,
nCol As Integer,
Style As TableCellStyle
)
public:
void SetCellStyle(
int nRow,
int nCol,
TableCellStyle^ Style
)
member SetCellStyle :
nRow : int *
nCol : int *
Style : TableCellStyle -> unit
Parameters
- nRow Int32
-
- nCol Int32
-
- Style TableCellStyle
-
ExceptionsException | Condition |
---|
ArgumentException |
The given row number nRow is invalid.
-or-
The given column number nCol is invalid.
-or-
Only allow to override cell style for header section or column header in body section.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
For standard schedule, must set the TableCellStyleOverrideOptions in the TableCellStyle to override this cell.
The global base format controls any non-overridden characteristics of this cell.
Examplepublic void FormatSubtitle(ViewSchedule colSchedule)
{
TableData colTableData = colSchedule.GetTableData();
TableSectionData tsd = colTableData.GetSectionData(SectionType.Header);
if (tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber))
{
TableCellStyle tcs = new TableCellStyle();
TableCellStyleOverrideOptions options = new TableCellStyleOverrideOptions();
options.FontSize = true;
options.Bold = true;
tcs.SetCellStyleOverrideOptions(options);
tcs.IsFontBold = true;
tcs.TextSize = 10;
tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs);
}
}
Public Sub FormatSubtitle(colSchedule As ViewSchedule)
Dim colTableData As TableData = colSchedule.GetTableData()
Dim tsd As TableSectionData = colTableData.GetSectionData(SectionType.Header)
If tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber) Then
Dim tcs As New TableCellStyle()
Dim options As New TableCellStyleOverrideOptions()
options.FontSize = True
options.Bold = True
tcs.SetCellStyleOverrideOptions(options)
tcs.IsFontBold = True
tcs.TextSize = 10
tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs)
End If
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also