BRepBuilderGetResult(ExternalGeometryId, BRepBuilderPersistentIds) Method |
Get the
ExternallyTaggedBRep built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder.
This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExternallyTaggedBRep GetResult(
ExternalGeometryId externalId,
BRepBuilderPersistentIds brepPersistentIds
)
Public Function GetResult (
externalId As ExternalGeometryId,
brepPersistentIds As BRepBuilderPersistentIds
) As ExternallyTaggedBRep
public:
ExternallyTaggedBRep^ GetResult(
ExternalGeometryId^ externalId,
BRepBuilderPersistentIds^ brepPersistentIds
)
member GetResult :
externalId : ExternalGeometryId *
brepPersistentIds : BRepBuilderPersistentIds -> ExternallyTaggedBRep
Parameters
- externalId ExternalGeometryId
-
The external Id of the GeometryObject built by this BRepBuilder.
- brepPersistentIds BRepBuilderPersistentIds
-
An object storing the relationship between ExternalGeometryIds and BRepBuilderGeometryIds.
Return Value
ExternallyTaggedBRep
The
ExternallyTaggedBRep built by this BRepBuilder.
ExceptionsException | Condition |
---|
ArgumentException |
At least one BRepBuilderGeometryId in the supplied BRepBuilderPersistentIds map could not be found in this BRepBuilder object.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This BRepBuilder object hasn't completed building data or was unsuccessful building it. Built Geometry is unavailable.
In order to access the built Geometry, Finish() must be called first. That will set the state to completed.
|
See Also