RevitLinkGraphicsSettingsColorFill Property |
The color fill of RevitLinkGraphicsSettings.
The color fill can be set to
ByHostView or
ByLinkView.
Only a view that supports color fill can have this property set to
ByLinkView.
To check if the view supports the color fill use
SupportedColorFillCategoryIds to see if there is any supported color fill category for the view.
The
LinkedViewId parameter must have a value assigned if this property is set to
ByLinkView.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic LinkVisibility ColorFill { get; set; }
Public Property ColorFill As LinkVisibility
Get
Set
public:
property LinkVisibility ColorFill {
LinkVisibility get ();
void set (LinkVisibility value);
}
member ColorFill : LinkVisibility with get, set
Property Value
LinkVisibility
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: Disallowed LinkVisibility value.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
See Also