DocumentNewFascia(FasciaType, Reference) Method |
Creates a fascia along a reference.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Fascia NewFascia(
FasciaType FasciaType,
Reference reference
)
Public Function NewFascia (
FasciaType As FasciaType,
reference As Reference
) As Fascia
public:
Fascia^ NewFascia(
FasciaType^ FasciaType,
Reference^ reference
)
member NewFascia :
FasciaType : FasciaType *
reference : Reference -> Fascia
Parameters
- FasciaType FasciaType
- The type of the fascia to create
- reference Reference
- A planar line or arc that represents the place where you
want to place the fascia.
Return Value
Fascia If successful a new fascia object within the project, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the fascia type does not exist in the given document. |
See Also