IOnLocalLinkSharedCoordinatesSavedCallback Interface |
A callback for notifying an IExternalResourceServer that
shared coordinates changes have been saved back to one
of the Revit or DWG links provided by that server.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic interface IOnLocalLinkSharedCoordinatesSavedCallback
Public Interface IOnLocalLinkSharedCoordinatesSavedCallback
public interface class IOnLocalLinkSharedCoordinatesSavedCallback
type IOnLocalLinkSharedCoordinatesSavedCallback = interface end
The IOnLocalLinkSharedCoordinatesSavedCallback type exposes the following members.
Methods | Name | Description |
---|
 | OnLocalLinkSharedCoordinatesSaved |
Revit will call this method whenever shared coordinates
changes are saved to a linked document provided by an
IExternalResourceServer. This call is a notification
to the server provider that one of their Revit or DWG
links has changed locally, and they should upload the
new version back to their server.
|
Top
Remarks
Revit will call OnLocalLinkSharedCoordinatesSaved whenever
shared coordinates changes are saved to a linked document
which is provided by an external server. This is a notification
to the server provider so they can copy the updated link
back up to their server.
See Also