BuiltInFailuresSystemsFailures Class

Failures about System.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresSystemsFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SystemsFailures

The BuiltInFailuresSystemsFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAddingOtherConnectedMembersToSystem "You have selected elements that are connected to other elements. These elements will also be added to the System."
Public propertyStatic memberCircuitWorksetClosedWarning The workset of the circuit is closed so the circuit path will not be displayed.
Public propertyStatic memberCreatePartsWithInvalidService Parts were not created because a system's service is undefined.
Public propertyStatic memberCreatePartsWithInvalidSystem Parts were not created because the element does not have a valid system.
Public propertyStatic memberCreatePartsWithoutDabasebase Parts were not created because fabrication configuration is not available.
Public propertyStatic memberDefaultSystemOver50Elems The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
Public propertyStatic memberElementsBelongToOtherSystem You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
Public propertyStatic memberFamilyDoesntMatchSystemProperties The family no longer matches the properties for the System. Disconnect the family from the System?
Public propertyStatic memberFamilyDoesntMatchSystemPropertiesWasDisconnected The family no longer matches the properties for the System. Disconnect the family from the System?
Public propertyStatic memberMismatchSystemType Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
Public propertyStatic memberPastePartsWithInvalidService Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.
Public propertyStatic memberSelectedElementsArePartOfOtherSystem You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.
Top
See Also