DocumentGetDefaultElementTypeId Method |
Gets the default element type id with the given DefaultElementType id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetDefaultElementTypeId(
ElementTypeGroup defaultTypeId
)
Public Function GetDefaultElementTypeId (
defaultTypeId As ElementTypeGroup
) As ElementId
public:
ElementId^ GetDefaultElementTypeId(
ElementTypeGroup defaultTypeId
)
member GetDefaultElementTypeId :
defaultTypeId : ElementTypeGroup -> ElementId
Parameters
- defaultTypeId ElementTypeGroup
-
The default element type id.
Return Value
ElementId
The element type id.
Exceptions
Exampleprivate bool IsWallUsingDefaultType(Document document, Wall wall)
{
ElementId defaultElementTypeId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType);
return (wall.WallType.Id == defaultElementTypeId);
}
Private Function IsWallUsingDefaultType(document As Document, wall As Wall) As Boolean
Dim defaultElementTypeId As ElementId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType)
Return (wall.WallType.Id = defaultElementTypeId)
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also