SubelementSetParameterValue Method |
Sets a new parameter value of this subelement given a parameter id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetParameterValue(
ElementId parameterId,
ParameterValue pValue
)
Public Sub SetParameterValue (
parameterId As ElementId,
pValue As ParameterValue
)
public:
void SetParameterValue(
ElementId^ parameterId,
ParameterValue^ pValue
)
member SetParameterValue :
parameterId : ElementId *
pValue : ParameterValue -> unit
Parameters
- parameterId ElementId
-
Parameter id.
- pValue ParameterValue
-
New value for the parameter.
ExceptionsException | Condition |
---|
ArgumentException |
parameterId does not identify a valid parameter of this subelement.
-or-
The parameter parameterId is not modifiable for this subelement.
|
ArgumentNullException |
A non-optional argument was null
|
See Also