TopographySurfaceGetInteriorPoints Method |
Gets all of the points that are not boundary points for the topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<XYZ> GetInteriorPoints()
Public Function GetInteriorPoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetInteriorPoints()
member GetInteriorPoints : unit -> IList<XYZ>
Return Value
IListXYZ
The collection of interior points.
Remarks
This applies to TopographySurface, SiteSubRegion, and the topography surface associated with a BuildingPad element.
For a SiteSubRegion, this returns the points inherited from the host TopographySurface.
For the topography surface associated with a BuildingPad element, this returns an empty collection.
See Also