ViewSetIsFilterEnabled Method |
Sets the filter enabled flag.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetIsFilterEnabled(
ElementId filterElementId,
bool enable
)
Public Sub SetIsFilterEnabled (
filterElementId As ElementId,
enable As Boolean
)
public:
void SetIsFilterEnabled(
ElementId^ filterElementId,
bool enable
)
member SetIsFilterEnabled :
filterElementId : ElementId *
enable : bool -> unit
Parameters
- filterElementId ElementId
-
The ElementId of the filter.
- enable Boolean
-
True if the specified filter should be enabled in this view, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
Filter is not applied to the view.
-or-
ElementId is not associated with a FilterElement.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The element "this View" does not belong to a project document.
-or-
The view type does not support Visibility/Graphics Overriddes.
|
Remarks
Several filters can be applied to a view in a sertain order. This enable/disable flag
allows one to quickly turn on/off the action of a particular filter in this view (without
removing the filter from the set of applied filters and loosing the corresponding overrides).
By default, all the filters applied to a view are enabled.
See Also