FilteredElementCollectorFirstElementId Method |
Returns the id of the first element to pass the filter(s).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId FirstElementId()
Public Function FirstElementId As ElementId
public:
ElementId^ FirstElementId()
member FirstElementId : unit -> ElementId
Return Value
ElementId
The first element id.
ExceptionsException | Condition |
---|
InvalidOperationException |
The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
|
Remarks
This will reset the collector to the beginning and find the first element that passes the applied filter(s).
If you have an active iterator to this same collector it will be stopped by this call.
ExampleFilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(View3D));
ElementId viewId = collector.FirstElementId();
if (FilteredElementCollector.IsViewValidForElementIteration(document, viewId))
{
FilteredElementCollector viewCollector = new FilteredElementCollector(document, viewId);
viewCollector.OfClass(typeof(FamilyInstance));
ICollection<ElementId> familyInstanceIds = viewCollector.ToElementIds();
document.Delete(familyInstanceIds);
}
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(View3D))
Dim viewId As ElementId = collector.FirstElementId()
If FilteredElementCollector.IsViewValidForElementIteration(document, viewId) Then
Dim viewCollector As New FilteredElementCollector(document, viewId)
viewCollector.OfClass(GetType(FamilyInstance))
Dim familyInstanceIds As ICollection(Of ElementId) = viewCollector.ToElementIds()
document.Delete(familyInstanceIds)
End If
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also