LocationCurveCurve Property |
Provides the ability to get and set the curve of a curve based element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Curve Curve { get; set; }
Public Property Curve As Curve
Get
Set
public:
property Curve^ Curve {
Curve^ get ();
void set (Curve^ value);
}
member Curve : Curve with get, set
Property Value
Curve
RemarksThis property can be used to set the location of curve based element to any desired
position. Many elements are curve based. Some examples are walls, beams and braces.
Examplevoid MoveUsingCurveParam(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
LocationCurve wallLine = wall.Location as LocationCurve;
XYZ p1 = XYZ.Zero;
XYZ p2 = new XYZ(10, 20, 0);
Line newWallLine = Line.CreateBound(p1, p2);
wallLine.Curve = newWallLine;
}
Private Sub MoveUsingCurveParam(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall)
Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
Dim p1 As XYZ = XYZ.Zero
Dim p2 As New XYZ(10, 20, 0)
Dim newWallLine As Line = Line.CreateBound(p1, p2)
wallLine.Curve = newWallLine
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also