AssemblyViewUtilsCreateSheet Method |
Creates a new sheet assembly view for the assembly instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ViewSheet CreateSheet(
Document document,
ElementId assemblyInstanceId,
ElementId titleBlockId
)
Public Shared Function CreateSheet (
document As Document,
assemblyInstanceId As ElementId,
titleBlockId As ElementId
) As ViewSheet
public:
static ViewSheet^ CreateSheet(
Document^ document,
ElementId^ assemblyInstanceId,
ElementId^ titleBlockId
)
static member CreateSheet :
document : Document *
assemblyInstanceId : ElementId *
titleBlockId : ElementId -> ViewSheet
Parameters
- document Document
-
The document to which the view will be added.
- assemblyInstanceId ElementId
-
Id of the assembly instance that owns the new view.
- titleBlockId ElementId
-
Id of the titleblock family to use. For no titleblock, pass invalidElementId.
Return Value
ViewSheet
A new sheet assembly view.
ExceptionsException | Condition |
---|
ArgumentException |
assemblyInstanceId is not an AssemblyInstance.
-or-
titleBlockId is not a TitleBlock.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
The document must be regenerated before using the sheet.
See Also