ParameterFilterElementCreate(Document, String, ICollectionElementId) Method |
Creates a new ParameterFilterElement in the given document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ParameterFilterElement Create(
Document aDocument,
string name,
ICollection<ElementId> categories
)
Public Shared Function Create (
aDocument As Document,
name As String,
categories As ICollection(Of ElementId)
) As ParameterFilterElement
public:
static ParameterFilterElement^ Create(
Document^ aDocument,
String^ name,
ICollection<ElementId^>^ categories
)
static member Create :
aDocument : Document *
name : string *
categories : ICollection<ElementId> -> ParameterFilterElement
Parameters
- aDocument Document
-
The document in which to create the ParameterFilterElement.
- name String
-
The user-visible name for the new ParameterFilterElement.
- categories ICollectionElementId
-
The categories for the new ParameterFilterElement.
Return Value
ParameterFilterElement
A pointer to the new ParameterFilterElement.
ExceptionsException | Condition |
---|
ArgumentException |
name is an empty string or contains only whitespace.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
The given value for name is already in use as a filter element name.
|
ArgumentNullException |
A non-optional argument was null
|
See Also