DividedPathIsIntersectorValidForDividedPath Method |
This returns true if the intersector is an element that can be used to intersect with the divided path.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsIntersectorValidForDividedPath(
ElementId intersector
)
Public Function IsIntersectorValidForDividedPath (
intersector As ElementId
) As Boolean
public:
bool IsIntersectorValidForDividedPath(
ElementId^ intersector
)
member IsIntersectorValidForDividedPath :
intersector : ElementId -> bool
Parameters
- intersector ElementId
-
The intersector.
Return Value
Boolean
True if the reference can be used to create a divided path, false otherwise.
Exceptions
Remarks
Intersectors can be curve elements, datum planes, or other divided paths.
Note that divided paths that have this divided path as an intersector
(either directly, or recursively) are not valid.
Also, if the nesting of divided path intersectors that have intersectors is more than 5 levels deep
the divided path intersector is considered invalid as well.
See Also