ParameterGetAssociatedGlobalParameter Method

Returns a global parameter, if any, currently associated with this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId GetAssociatedGlobalParameter()

Return Value

ElementId
Id of a global parameter or InvalidElemetnId.
Exceptions
ExceptionCondition
ArgumentException This parameter does not exist in the document anymore.
Remarks
InvalidElementId is returned in case this parameter is not associated with any global parameter. InvalidElementId is also returned if called for a parameter that cannot even be associated with a global parameters (i.e. a non-parametrizable parameter or parameter with a formula).
See Also