FilledRegionTypeIsValidForegroundPatternId Method |
Check if the id is valid for a foreground pattern
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidForegroundPatternId(
ElementId patternId
)
Public Function IsValidForegroundPatternId (
patternId As ElementId
) As Boolean
public:
bool IsValidForegroundPatternId(
ElementId^ patternId
)
member IsValidForegroundPatternId :
patternId : ElementId -> bool
Parameters
- patternId ElementId
-
Element id of the FillPatternElement
Return Value
Boolean
False if in a family, and the id is a FillPatternElement that targets 'Drafting'.
True otherwise.
Exceptions
Remarks
In a family the FillPatternElement must be a 'Drafting' pattern.
See Also