ElectricalLoadClassificationDemandFactorId Property |
The demand factor definition this load classification element uses.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId DemandFactorId { get; set; }
Public Property DemandFactorId As ElementId
Get
Set
public:
property ElementId^ DemandFactorId {
ElementId^ get ();
void set (ElementId^ value);
}
member DemandFactorId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The element id elemId is not a valid ElectricalDemandFactorDefinition element.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also