AnalyticalNodeDataGetAnalyticalNodeData Method

Returns AnalyticalNodeData associated with this element, if it exists.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static AnalyticalNodeData GetAnalyticalNodeData(
	Element element
)

Parameters

element  Element
The element from which we try to obtain AnalyticalNodeData.

Return Value

AnalyticalNodeData
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
If the input element doesn't have AnalyticalNodeData than it retuns . The input element should be a ReferencePoint.
See Also